« Ad[es]の2.00a | トップページ | その後のTime Capsule »

2008年3月21日 (金)

無線LANが死んだ

MacBookBoot Campに入れてるWindows Vistaの環境にSP1を適用してみましたが、そのWindows Vistaでスリープから復帰した際にネットワークに繋がらない状態になりました。

なんでだろう?と思って確認すると、ただ無線APを見つけられない状態ではなく、無線デバイス自体が存在しない状態になっていました。
デバイスマネージャーで確認してもエラーになっているだけではなく、存在すらしていません。

Windows Vistaのスリープからの復帰がSP1の適用によって速くなったのでその副作用かな?と思ったり、どうせ再起動したら直るんだろうと軽く考えて再起動してみるものの相変わらずデバイスが出てきません・・・

一瞬SP1を適用したことを後悔しつつも、Leopardで問題なければいいやと思ってLeopardを起動してみましたが、こちらも同じく無線LANに繋がりません。
おまけに右上のAirMacインジケーターをクリックすると、「AirMacカードがインストールされていません」といったエラーが出ます。

・・・こ、壊れたのかなcrying と思いつつネットで情報を探ってみると、何やら一旦英語環境で起動すると直るとの情報を見つけました。
(参考にさせて頂いたサイトはこちら

その情報に従って環境設定で英語を選択して再起動・・・暫くすると英語環境のLeopardが起動してきました。
当然Finderのメニュー表記も英語になっていますが、驚くことにこの時点で既に無線LANに接続されていますcoldsweats01

その後環境を日本に戻して確認したところ、問題なく元通りに直っているようです。
ついでにBoot CampのWindows Vistaでも確認してみましたが、こちらも問題なさそうです。

今までLeopardでスリープを多用しててもこういった現象になったことはありませんし、たまたまWindows Vistaのスリープ復帰と重なっただけかもしれませんが、今までのWindowsPCでの経験上、ハード故障かと思ってびっくりしましたcoldsweats01

ただ、今回は無事に直ったので良かったものの、原因が分からないのでパッとしません。
素人考えだと、Boot CampのWindows Vista上でデバイス自体が存在しないってことは、ハードウェア的に存在していないということではないんでしょうか?
なのに英語環境でLeopardを起動するだけでBoot Campの方にも影響してデバイスが復活する理由が良く分かりません。
WindowsPCで例えると、BIOSでハードウェアの使用可否を変更しているのと同じ事をしてるのかな?
Macって奥が深いなぁhappy02(意味不明)

« Ad[es]の2.00a | トップページ | その後のTime Capsule »

コメント

コメントを書く

コメントは記事投稿者が公開するまで表示されません。

(ウェブ上には掲載しません)

トラックバック

この記事のトラックバックURL:
http://app.cocolog-nifty.com/t/trackback/182846/40586203

この記事へのトラックバック一覧です: 無線LANが死んだ:

« Ad[es]の2.00a | トップページ | その後のTime Capsule »